Site /

Building

Gede

Downloads

Documentation

Support

edit SideBar

Building

Dependencies

Gede depends on Qt5, python3 and exuberant-ctags.

Make sure that you have all dependencies installed.

On Debian/Ubuntu/Mint:

sudo apt-get install gdb
sudo apt-get install build-essential
sudo apt-get install exuberant-ctags
sudo apt-get install python3
sudo apt-get install qt5-qmake qtbase5-dev

On Redhat/Centos:

sudo yum install gcc
sudo yum install gcc-c++
sudo yum install ctags
sudo yum install qt5-designer qt5-devel

On FreeBSD:

pkg install gdb
pkg install universal-ctags-g20180225
pkg install qt5
pkg install gcc

Building

Extract:

 tar -xvJf gede-x.y.z.tar.xz

Compile and install (to /usr/local/bin):

 sudo make install

Gede can now be launched:

Creating .deb packages

To create .deb packages you need to install debuild:

sudo apt-get install devscripts debhelper

Creating (binary) debian packages by running:

./create_deb_files.py

The deb files will be placed in the directory above the current directory.

Recent Changes (All) | Edit SideBar Page last modified on November 26, 2021, at 07:44 PM Edit Page | Page History
Powered by PmWiki